alt.org stuff - Problems with this forum or with alt.org in general?
 
User: [Log In] [Create A New Profile]
Actions: [New Topic] [Print View] [RSS]
Search
Path: [NAO] [Forums] [alt.org stuff]
Topic:
Rogue level graphics? (10 Posts)
Started By:
Date:
November 08, 2009 06:35PM

Rogue level graphics?
DarthL33tSA - November 08, 2009 06:35PM
 
On PuTTY at least, the Rogue level never looks right with IBMGraphics on. Monsters are missing or misaligned, and the stairs are in a different place than displayed. Does anyone else have this issue?
 

Re: Rogue level graphics?
SmashFan2005 - November 08, 2009 07:47PM
 
I don't know.. I've never used PuTTY. IBM graphics doesn't really work with the Java app either.
 

Re: Rogue level graphics?
dtype - November 10, 2009 06:28AM
 
To be honest I haven't looked at that Java app in years. I don't really suggest it as anything other than a last resort, although if there is a better one out there we can always put it up on NAO.

Generally putty is the best bet all around for telnet from Windows though.
 

Re: Rogue level graphics?
bofh69 - November 14, 2009 03:38PM
 
Soiled is a TELNET client and partial vt100/vt102/xterm terminal emulator implemented in flash that works quite well for playing NetHack with. I don't think it supports IBMGraphics yet though, only DECGraphics, but it can be added if needed.
 

Re: Rogue level graphics?
paxed - November 16, 2009 08:04AM
 
bofh69 Wrote:
-------------------------------------------------------
> Soiled is a TELNET client and partial
> vt100/vt102/xterm terminal emulator implemented in
> flash that works quite well for playing NetHack
> with. I don't think it supports IBMGraphics yet
> though, only DECGraphics, but it can be added if
> needed.

Well, I just retried it, and the same thing happened as the last time I tried setting it up: I can't seem to get it working. Yes, the policy-file is served correctly, AFAICS, but it still complains about a security error.

-- 
You( "are momentarily disoriented." );
 

Re: Rogue level graphics?
bofh69 - November 16, 2009 09:50AM
 
paxed Wrote:
> Well, I just retried it, and the same thing
> happened as the last time I tried setting it up: I
> can't seem to get it working. Yes, the policy-file
> is served correctly, AFAICS, but it still
> complains about a security error.


I just tried to connect to nethack.alt.org, port 843 and I got "Connection refused", but perhaps you removed it again? The policy file needs to be served from the same domain name as the flash-app is trying to connect to (not the domain that the flash app is being downloaded from). See dum.acc.umu.se, port 843 for another example of a policy file. If you start serving the policy file again, I can probably debug it for you.
 

Soiled policy file, was Re: Rogue level graphics?
paxed - November 16, 2009 11:13AM
 
bofh69 Wrote:
-------------------------------------------------------
> paxed Wrote:
> > Well, I just retried it, and the same thing
> > happened as the last time I tried setting it up:
> I
> > can't seem to get it working. Yes, the
> policy-file
> > is served correctly, AFAICS, but it still
> > complains about a security error.
>
>
> I just tried to connect to nethack.alt.org, port
> 843 and I got "Connection refused", but perhaps
> you removed it again? The policy file needs to be
> served from the same domain name as the flash-app
> is trying to connect to (not the domain that the
> flash app is being downloaded from). See
> dum.acc.umu.se, port 843 for another example of a
> policy file. If you start serving the policy file
> again, I can probably debug it for you.

The policy file is served on port 14322

-- 
You( "are momentarily disoriented." );



Edited 1 time(s). Last edit at 11/16/2009 11:14AM by paxed.
 

Re: Soiled policy file, was Re: Rogue level graphics?
paxed - November 16, 2009 04:09PM
 
Interestingly, It Now Works; 8-) the non-working bit may have had something to do with me being at work. But I'm not going to use it until few issues are fixed... I'll put those in to the soiled's issue tracker, though.

Edit: I managed to compile the code, and changed the biggest issues I had with it: the default colors. So, now it's there.

-- 
You( "are momentarily disoriented." );



Edited 1 time(s). Last edit at 11/16/2009 06:53PM by paxed.
 

Re: Rogue level graphics?
gelbschnee - November 10, 2009 07:08AM
 
I use putty as well, with no problems. I'd suggest it to anybody.
 

Re: Rogue level graphics?
n0m - May 05, 2010 09:03AM
 
DarthL33tSA Wrote:
-------------------------------------------------------
> On PuTTY at least, the Rogue level never looks
> right with IBMGraphics on. Monsters are missing
> or misaligned, and the stairs are in a different
> place than displayed. Does anyone else have this
> issue?


Yes, and I'm pretty sure I've figured out the cause and half a workaround.
Cause: The character that replaces @ in the rogue level is some kind of escape character in PuTTy.
Workaround: Turn "showrace" on, only works for dwarves, orcs, and gnomes.

There isn't an option to change the rogue graphics in the config file, a more permanent solution would need a patch to either NAO or PuTTy.
 

Go to Topic: [Previous] [Next]